分类 标签 存档 黑客派 订阅 搜索

Migration is required due to the following errors

258 浏览

前几天在给 Realm 数据库的一个表加字段的时候, 控制台报了一个错.Migration is required due to the following errors

网上 Google, 然后看了一下官方文档.

//在Appdelegate加上这个代码段就行了.
// Inside your application(application:didFinishLaunchingWithOptions:)

let config = Realm.Configuration(
    // Set the new schema version. This must be greater than the previously used
    // version (if you've never set a schema version before, the version is 0).
    schemaVersion: 1,

    // Set the block which will be called automatically when opening a Realm with
    // a schema version lower than the one set above
    migrationBlock: { migration, oldSchemaVersion in
        // We haven’t migrated anything yet, so oldSchemaVersion == 0
        if (oldSchemaVersion < 1) {
            // Nothing to do!
            // Realm will automatically detect new properties and removed properties
            // And will update the schema on disk automatically
        }
    })

// Tell Realm to use this new configuration object for the default Realm
Realm.Configuration.defaultConfiguration = config

// Now that we've told Realm how to handle the schema change, opening the file
// will automatically perform the migration
let realm = try! Realm()

可能碰到其他需求, 可以参考文档.🙂 文档地址

--EOF--

评论  
留下你的脚步
推荐阅读